Armando el cable DCA-510 para siemenes

Ayer realize la compra de un cable en mercadolibre para poder bajar y hacer cosas con mi celuar (Siemenes CX65). Cuando realize la compra da descripcion del mismo decia DCA-510, pero era un kq-u8a.

La direfencia radica aparte del precio, es que con el DCA-510 se puede hacer todo, y con el otro nada
Aparte para poder logar que se comunicara de forma mala o no se comunicara, el kq-u8a es mas facil de conseguir en mercado y aparte se necesitan uno programas ATenable para poder logara algo, y ni hablar de los drivers que no estan por ningun lado.
Entonces despues de navegar un buen rato, y leer mucho descubimos como podiamos convertirlo de forma facil.

Materiales:

2 resistencias de 15k ( Marron / Verde / Naranja )
1 destornillador chato
Soldador y estaño
Pulso !

Que hacemos:

en el pin 7 sacamos es cable y junto con el pin 5 le soldamos una rasistencia a cada cable.
y todo lo unico al pin 2 y listo, para comprobar conectamos al USB y la otra punta al cel,

DCA-510-1 final
luego discamos *#06#, le damos mas y buscamos ACC:

( con el kq-u8a )

ACC. NONE

( con el DCA-510 )

ACC: Plugged in DCA-510

Y listo, con eso podemos subir, bajar cosas. Solo que debemos de conectarlo apagado y encenderlo con el cable conectado, abrimos el MPM, el Simoco o el Administrador que queremos y listo. Solo que queda probar si puedo actualizar el FW y pasar a usar el FW del cx70.

NOTA: XMPM es el soft de Benq-Siemens que se pude correr en GNU/Linux, requiere Java. Si no se puede usar SieFS junto con el modulo pl2303 (usando este cable) que viene en los kernels genericos o si lo compilas, busca en la parte de USB.

Al xmpm requiere la JVM 1.4.2, debian instala la 1.5 así que para hacerlo funcionar modifique el archivo que esta en /opt/xmpm/bin/xmpm:

function validate_java()
{
[ -x “$1” ] || return 1;

version=$(“$1” -version 2>&1);
if echo “$version” | grep -q ‘Java(TM)’ &&
echo “$version” | grep -q ‘1.4.2’ &&
echo “$version” | grep -q ‘Standard Edition’; then
return 0;
else
return 1;
fi
}

Por esta:

function validate_java()
{
[ -x “$1” ] || return 1;

version=$(“$1” -version 2>&1);
if echo “$version” | grep -q ‘Java(TM)’ &&
echo “$version” | grep -q ‘1.4.2’ || echo “$version” | grep -q ‘1.5’
echo “$version” | grep -q ‘Standard Edition’; then
return 0;
else
return 1;
fi
}

Que hizimos, forzamos a que use la version mas nueva de JAVA!, Todavia no puedo hacer que el programa me vea el cable, en cuanto lo tenga actualizo el blog….

NO ME HAGO RESPONSABLE SI ALGO SALE MAL